Use of Internet Explorer on Campus

July 17, 2014
On April 29, 2014 ITS issued a BearAware Alert for all versions of Internet Explorer. The campus was instructed to use another browser until Microsoft issued a patch to fix the vulnerability in Internet Explorer. We appreciate the campus response to the warning and your cooperation in using a different browser until a fix was released. ITS has been actively installing the patch to computers connected to the network since the release of the fix in May. As long as your computer has been connected to the network or if you have received a new computer since the alert, you may use Internet Explorer as your browser. The current version of Internet Explorer that is approved for campus use is version 9. Please contact the Help Desk at 254-710-4357 if you have any questions.
Are you looking for more news?