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More Than Just Good Looks
Graphics Tools
FileMaker Pro provides you with some graphic layout tools that allow you to “dress up” your 

layout.  You must first be in the Layout Mode to use these tools.

The Fill Color Palette allows you to choose the fill 

color of any layout object.  First you must select the 

object, then select the color.  The Fill Pattern 

Paletteallows you to choose the fill pattern of a 

layout object.  Again, you must select the object and 

then select the pattern.  The Object Effects Palette

allows you to give objects a 3-dimensional 

appearance.

The Line Color Palette allows you to choose the 

line color of an object.  First you must select the 

object, then select the color.  The Line Pattern 

Paletteallows you to choose the line pattern of any 

object.  Again, you just select the object and then 

select the pattern.  You can also select the line width 

with the Line Width Menu .

More on Layout Tools
The Button Tool
The Button Tool allows you to create buttons that 

will perform scripts.

The View Menu

Fill Color Palette

Line Color Palette

Object Effects Palette

Fill Pattern Palette

Line Pattern Palette

Line Width Menu

The Button Tool

Page Marginsshow the page margins in gray on the layout.

Graphic Ruler places a ruler across the top and on the left 

side of the layout window.

Text Ruler places a ruler across the top of the layout 

window.

Ruler Lines places dotted lines on the layout to aid in 

alignment.

T-Squaresplaces a vertical and horizontal line on the layout 

to aid in alignment.

Object Sizedisplays a window that shows the size of the 

object selected.
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More Layout Tools
The View Menu (continued)

When you select Show, you will get the 

following choices:

•Buttons–FileMaker will highlight 

all of the buttons that are in the 

layout.

•Sample Data–FileMaker will insert 

sample data into the fields.  This will 

help to adjust field lengths.

•Text Boundaries–FileMaker will 

highlight the boundaries surrounding 

the text in the layout. 

•Field Boundaries–FileMaker will highlight the boundaries surrounding the fields in 

the layout.

•Sliding Objects–FileMaker will highlight all of the sliding objects with an arrow 

denoting the direction of the slide.

•Non-Printing Objects–FileMaker will highlight all of the non-printing objects.  

Examples of non-printing objects might be buttons or instructions.

When you select Toolbars, you will get the option of viewing different toolbars.  The choices 

will change depending on the mode you are in.  Below are examples of some of the different 

toolbars: 

Standard Formatting Toolbar

Text Formatting Toolbar

The Status Areagives you the option to view the gray bar on the left hand side of your database 

or not.

The Status Bargives you the option to view instructions or details about a currently selected 

item.

Zoom In will make the items on the screen appear larger.

Zoom Out will make the items on the screen appear smaller.
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The Arrange Menu

•Group –FileMaker will take all of the objects that are selected 

and group them into one object.

•Ungroup–The group will be broken apart into the original set 

of objects.

•Lock–FileMaker will lock the selected object so that it cannot 

be changed or deleted.

•Unlock–The object that was locked will be unlocked.

•Bring to Front –FileMaker will bring the selected object to the 

top layer.

•Bring Forward –FileMaker will bring the selected object 

forward, one layer at a time.

•Send to Back–FileMaker will send the selected object to the 

bottom layer.

•Send Backward–FileMaker will send the selected object 

backward, one layer at a time.

•Rotate–FileMaker will rotate the selected object 90º at a time.

•Align or Set Alignment–FileMaker aligns the selected objects.  Choose 

Set Alignment for the alignment options.

•Object Grids - FileMaker limits the movements and adjustments of 

selected objects to coincide with grid coordinates.

More on Colors

You can add custom colors to the components of 

your database.  

•In the Layout mode, select the object you 

wish to add color to and click on the Fill 

button and select Other Color . 

•Select one of the empty boxes and pick a 

color from the color palette on the right.

•Click the Add to Custom Color button.

•Click OK .
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More Layout Tools

The Format Menu

The first two sections of the Format Menu contain text 

and specific field formatting options such as number and 

date.

The Field/Control option will display the Field/Control 

set-up window and allow you to change the way the 

selected field will behave. (See next section.)

The Field Borders option will allow you to choose the 

type of border you want for the selected field.

The Sliding/Printing option will allow you to choose 

whether or not the selected object will be printed and 

whether or not the selected field will have the information 

in it slide to one side or the other. 

Field Control Setup
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Using a value list with a field allows you to have control over the data that is entered for that 

field.  You can format the field to display the list in several ways.

Pop-up list/menu Radio Buttons Checkboxes

By default, a field is considered an Edit Box.  If you have created a value list and then at 

some point decide to remove the value list, you would select Edit Box as the field format.

Note:  You must have defined a value list to use these formats.

To format a field to display as an edit box, pop-up list, pop-up menu, checkboxes, or 

radio buttons:

1. In the layout mode, select the field.

2. From the Format menu, choose Field/Control , then Setup.

3. In the Field/Control Setup dialog box, select options from the Control Style area:



Choose the format you want 

from the first pop-up list.

Choose the name of the value list 

from the second pop-up list.  

Choose Manage Value Liststo 

create a new value list.

Select Include ñOtheréò item 

to allow entry of other values.  

This option is not available for 

fields formatted as pop-up lists.

4.      Click OK.

5.      Resize the field on the layout until you get the arrangement you want.  Depending on the 

proportions of the field, FileMaker aligns checkboxes and radio buttons either in rows or 

columns.
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Select Include ñEditéò item to allow editing of value list.  This option is not available 

for fields formatted as checkboxes, radio buttons, or for value lists based on another field’s 

values.

To see pop-up lists or pop-up menus, you must switch to the Browse or Find mode.



Creating a Value List
When you want to provide a fast, accurate way to enter or validate data in fields, use a value list.  

A value list lets you define frequently used text, number, date, or time values and then display 

them in the field in a pop-up menu, a pop-up list, as a series of checkboxes, or as radio buttons.  

Value lists are not attached to a field definition.  They can be shared by many fields.  The values 

in a value list can be user-defined, or based on the values in a field in the same file or in a 

different file.

To define a value list:

1. From the Field/Control Setup dialog box, select Manage Value Listsé

2. In the Manage Value Lists dialog box, click the New button.

The Edit Value List dialog box will appear.

3. For Value List Name, type a name for the list.

4.   In the box next to Use custom values:, type each value on a separate line, in the order you 

want them to appear. To create a separator, type a hyphen on a line by itself where you 

want the separator to appear.

5.   Click OK .
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Using Value Lists for Summary Totals

You can use value lists to track information and produce totals for specific items.  In the 

example below, each record indicates which size t-shirt is needed and how many t-shirts of 

each size will need to be ordered. 

The first step is to create a field for each shirt size.  To do this:

1. Click on the File menu

2. Select Manage, then select Database
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The following window will appear:

In the Field Name box, enter one of the t-shirt sizes, i.e. “Small” and click the Create button.  

Repeat this process for the other t-shirt sizes.  These fields should all be created as Text fields.
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Next, you will need to create a Summary field for each t-shirt size.  This will contain the total 

amount of shirts needed of a particular size.  In the Field Name box, enter a name such as 

“Total Small” and select the Type as “Summary” and click the Create button.

Do this for each t-shirt size.  Then click OK to close the windows.

In the Options box, select the “Count of” button and select the appropriate size in the 

“Available Fields” list.  Click the OK button.
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Next, we will create a Value List for each t-shirt size.  This list will only contain one item –the 

t-shirt size.  Click on the File menu, select Manage, and then Value Lists…

The following window will appear:

Click on the “New” button.
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In the next window, enter a descriptive name for the value list, such as the t-shirt size.  In the 

“Use custom values” section, enter the t-shirt size.  Then click the OK button.  

Create a different value list for each t-shirt size.
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In the Layout Mode, you  may want to delete the field labels, and arrange the sizes together 

with one descriptive label, such as “T-Shirt Size”

The next step is to connect each shirt size with it’s value list that we created earlier.  Right-

click on the “Small” field and select “Field/Control” and then “Setup”.
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In the Control Style section, set “Display as:” to “Checkbox Set”.  Next, set “Display 

values from” to the appropriate shirt size –Small for this example.  Then click the OK 

button.

Repeat this process for each shirt size.  

Now for each record, you can indicate which size the student wants, as well as keeping a 

total of how many of each shirt size will need to be ordered for all students.
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Creating a Layout with Tab Controls

A layout can be arranged in a tabbed format, where each tab contains the fields relevant to 

that description.  For example, you can have tabs labeled “Admission Info”, which would 

contain the fields related to a student’s admission.

To create the layout with tabbed information, go to the Layout Mode and create a new 

layout.  Select all of the fields that you want in your tabs.  Decided what you want to name 

your tabs –we will use:  Admission Info, Local Address, Home Address, T-Shirt Info, and 

Driver Information.

Using the Tab Control tool       , click and drag the area you want on your layout for the 

tabbed information.  It will draw a rectangle as you drag.  When the area you want is in the 

rectangle, let go of the mouse button.  The following window will appear:
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Enter the tab names that you want on your layout in the Tab Name field (one at a time) and 

click the “Create” button.  Once you have entered all of your tab names, click the OK 

button.  Your tabbed layout will appear on the screen.

Drag the fields to the appropriate tabs.  You can make the tabs a different color by 

selecting the tab, clicking on the Fill Color button, and selecting the desired color.
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More on the Web Viewer

To insert a window that will display a web browser, click on the Web Viewer tool       , and 

click and drag to draw the area in which the web page will appear.  When you release the 

mouse button, this window will appear:  

You can choose one of the pre-programmed sites, such as Google Maps.  You can enter 

a URL that is not listed, such as:  http://www.baylor.edu.  To do this, in the Choose a 

Website section, select “Custom Web Address”.  Then, click on the Specify button.
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In the Specify Calculation window, remove the information in the formula area and enter 

the desired URL.  Make sure that the URL is within quotation marks.  Then click OK and 

OK again.

In the Browse Mode, a web browser window will appear for each record in your 

FileMaker database.  For the pre-programmed sites, such as Google Maps, it allows 

you to match fields so that it will look up information specific to each record, such 

as Address.  For the Custom Web Address, I’m still working on a way to insert 

lookup fields in the formula.  

As always, if you have any questions, please call me at x4357.   Thanks!!
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FileMaker Pro ðMore Than Good Looks

1. Make sure you are in the Layout Mode.

2. Create a new layout –select Standard.

3.      Try out the new Layout Tools and the Layout Menus.

4. Create a button that will add a new record but won’t be printed out if the 

screen is printed.

5. Create a few more buttons of your choice.

6.      Create a Value List for Student Org: Alpha Chi Omega

Delta Delta Delta

Fencing Club

German Club

Heavenly Voices

7. Create a Value List for Classification: Freshman

Sophomore

Junior

Senior

8.      Use a Value List for summary totals:

ü Create text fields for each shirt size

ü Create a value list for each shirt size with only one value

ü Attach value list to appropriate shirt size field

ü Delete field labels for shirt size and make one generic label: Shirt Size

ü Select shirt size for each record

ü Create Summary fields for each shirt size as a “Count of” the selected 

size
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FileMaker ProðMore Than Good Looks   

More practiceé

Create a tabbed layout:   

Admission Info

Local Address

Home Address

T-Shirt Info

Move fields into the appropriate tabbed area

Add a web viewer:

Create a layout with a web viewer that will show a map to local address

Copy Google Map image onto layout

Add Conditional Formatting to a Field

• Right-click on the “Hours taken this semester” field

• Click the Add button

• Set the Condition to:  Value is greater than 12

• Make the text Bold and Red

• Click OK

This will flag a student who is taking a heavy load of classes for the semester.
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