Recommended Browsers

Supported Browsers

As of May 24, 2014, Canvas supports the following desktop browsers:

  • IE logoInternet Explorer - 10 & 11
  • Chrome logoChrome *
  • Safari logoSafari - 6 & 7
  • Firefox logoFirefox *

Some supported browsers may still produce a banner stating Your browser does not meet the minimum requirements for Canvas. If you have upgraded your browser but you are still seeing the warning banner, try logging out of Canvas and deleting your browser cookies. Click here for help with clearing your cache.

* Because Firefox and Chrome release new versions so quickly, please visit the Instructure web site to check the latest supported releases for these browsers. This site is also useful for verifying Flash and Java compatibility.

Mobile Browsers

For a better user experience on mobile devices, consider using the official Instructure mobile apps for Canvas. To view a list a supported mobile browsers, visit the Instructure web site.

Verifying Browser Versions

To determine the version of your particular browser, visit Thismachine.info.

Firefox ESR in Classrooms & Labs

Baylor computer labs supported by the Electronic Library use a version of Firefox called "Extended Service Release" that is not officially supported by Instructure. When using this browser, users will see the Your browser does not meet the minimum requirements for Canvas warning. Users may dismiss this warning since there are no known incompatibilities with Firefox ESR. However, users who do encounter problems with Firefox ESR in lab environments should use a different browser and are encouraged to call the Help Desk at (254) 710-HELP to report any issues.